Автоматизация рутины в OS X. Урок 12. Работаем с электронными таблицами

Автоматизация рутины в OS X. Урок 12. Работаем с электронными таблицами

Numbers — это аналог Microsoft Office Excel, который входит в стандартную комплектацию OS X. Во многих предыдущих уроках мы поверхностно касались темы взаимодействия этого приложения и Java Script Automation. В этом уроке раскроем ее более подробно.

Куда писать автоматизирующий код?

  1. Открыть программу «Редактор скриптов» (Программы -> Утилиты).
    Снимок экрана 2015-10-10 в 21.02.41
  2. В верхнем меню выбрать Файл -> Новый.Снимок экрана 2015-10-10 в 21.08.11
  3. На переключателе языков выбрать JavaScript.

Снимок экрана 2015-10-10 в 21.11.37

Как создать новую электронную таблицу?

// Создаем переменную для приложения Numbers
Numbers = Application('Numbers');
//Создаем новый документ
 var newReport = Numbers.Document().make();

Как записать данные в ячейку электронной таблицы?

// Создаем переменную для приложения Numbers
Numbers = Application('Numbers');
// Создаем новый документ
 var newExcel = Numbers.Document().make();
// Создаем переменную для обращения к первому листу документу
 var sheet = newExcel.sheets[0];
// Создаем переменную для обращения к первой таблице первого листа документа
 var table = sheet.tables[0];
//Записываем значение в ячейку
 table.cells["A1"].value=1;

Как записать данные в несколько ячеек электронной таблицы?

Вот таким образом можно заполнить ячейки одного столбца:

for (i=1; i<=10;i++)
{
table.cells["A" + i ].value=i;
}

 

Как вставить в ячейку формулу?

Снимок экрана 2015-10-16 в 20.34.50

table.cells["A1"].value=1;
table.cells["A2"].value=2;
table.cells["A3"].value="=СУММ(A1:A2)";

Где посмотреть подробную информацию обо всех функциях, которые поддерживаются Numbers?

Для того чтобы с правой стороны экрана появилась панель со справкой обо всех функциях необходимо два раза кликнуть на голубой ярлык с надписью «Функция» на верхней панели инструментов.

Как изменить форматирование ячейки?

Снимок экрана 2015-10-16 в 20.20.28

// Меняем имя шрифт
table.cells["A1"].fontName="Arial";
// Размер шрифта
 table.cells["A1"].fontSize="25";
// Выравнивание текста
 table.cells["A1"].alignment="center";
// Цвет текста
 table.cells["A1"].textColor="white"
// Цвет фона в ячейке
 table.cells["A1"].backgroundColor="red";

Как экспортировать файл .numbers в .xlsx?

Numbers = Application('Numbers');
var pathNumbers = Path("/Users/irina/Desktop/toexport.numbers");
// Открываем файл в формате Numbers, который будем экспортировать
var newExcel = Numbers.open(pathNumbers);
// Задаем путь и имя выходного файла
var pathExcel = Path("/Users/irina/Desktop/toexport.xlsx");
// Экспортируем файл
newExcel.export({to: pathNumbers, as: 'Microsoft Excel'});

Предыдущие публикации из цикла «Автоматизация рутины в OS X» вы можете найти по следующим ссылкам:

Список полезных тем:


Поставьте оценку: 1 звезда2 звезды3 звезды4 звезды5 звезд (5,00 из 5, оценили: 2)
Загрузка...

Вернуться в начало статьи Автоматизация рутины в OS X. Урок 12. Работаем с электронными таблицами

Добавить комментарий